rr_ssl_weak_server_ephemeral_dh_key

chrome

有些https加密的网站在IE中能够访问,但是Firefox/Chrome中会出现rr_ssl_weak_server_ephemeral_dh_key这样的错误码。究其原因,还是新版本的浏览器放弃了对SSL1/2/3/TLSv1(TLSv1.1?不清楚)的支持,要求必须强制使用TLSv1.2(或者更高?)版本的安全协议。另附JDK中支持的协议说明:

Here are the available protocols on each platform.

Platform Available Protocols
JDK 5, 6 SSLv2Hello(1), SSLv3, TLSv1
JDK 7, 8, 9 (Early Access) SSLv2Hello(2), SSLv3, TLSv1, TLSv1.1, TLSv1.2

 


扫一扫在手机上看

发表评论

电子邮件地址不会被公开。 必填项已用*标注